Help RMX2086 ISP pinout

deadmau0703

Member
Oct 21, 2022
9
0
algeria
hello ,

My brother bought a new RMX2086 and wanted a custom rom on this it , i got it running without a problem for him everything was working fine till he connected the phone and he mistakenly formated the phone storage using UnlockTool using the "Snapdragon" tab.

I Tried reviving it using QFil and Unlocktool but it got no success and the phone only connect into EDL mode 9008.
i tried many firmwares but i got no luck.

but the other day i tried another RMX2086 firmware but the phone is hard hard bricked now , what i mean is the phone is not connecting to the pc anymore No 9008 no Fastboot no nothing it is dead , i read on this forum that SDM855+ has ram over it so i can't dig to ISP pinout.

anyone can help
 

deadmau0703

Member
Oct 21, 2022
9
0
algeria
i think i found the test point for this stupid phone ,
i flashed the same firmware that i used to revive this phone with but i got no EDL without shorting or fastboot , nothing , i have to short it to get 9008 port .
photo_2023-05-28_23-04-08.jpg
 

deadmau0703

Member
Oct 21, 2022
9
0
algeria
hey guys i tried 3 difrrent ofp , extracted them and flashed the firmware using Unlocktool's SDM module , with the help of prog_firehose.mbn from Unlocktool server. the one that came with the firmware does not work .

but the phone is still dead and with the usb plugged in it draws 0.25 to 0.30 Amps
here's the log..

Version:0.9 StartHTML:-1 EndHTML:-1 StartFragment:000128 EndFragment:017079 SourceURL:file%3a%2f%2f

EDL FLASH

Selected Model : Realme X3 SuperZoom
Code Name : RMX2086
Operation : Auth Flash
Authenticating... OK
Retrieving data... OK [291.56 KiB]
Initializing data... OK
Waiting for HS-USB QDLoader 9008... COM7
Connecting to device... OK
Writing flash programmer... OK
Connecting to flash programmer... OK
Configuring device... OK
Setting boot LUN1... OK
Firehose config : UFS [Sector:4096] [Target:0] [Host:1048576]

Processing LUN0 - rawprogram0.xml
Writing persist.img [ext4:32 MiB]->persist... OK 0.815s
Writing custom.img [sparse:4.12 MiB]->custom... OK 0.219s
Writing cache.img [sparse:68.17 KiB]->cache... OK 0.107s
Writing metadata.img [sparse:44.07 KiB]->metadata... OK 0.103s
super->super.img is not exists!!!
Writing super.0.3743af72.img [sparse:3.9 GiB]->super... OK 100.494s
Writing super.1.ad242118.img [sparse:2.23 GiB]->super... OK 59.572s
Writing super.2.ad8e3c51.img [sparse:1.01 GiB]->super... OK 26.933s
Writing userdata.img [sparse:345.32 MiB]->userdata... OK 9.409s
Writing gpt_main0.bin [raw:24 KiB]->PrimaryGPT... OK 0.102s
Writing gpt_backup0.bin [raw:20 KiB]->BackupGPT... OK 0.102s
Applying patch0.xml... OK

Processing LUN1 - rawprogram1.xml

Writing xbl.elf [elf:3.04 MiB]->xbl... OK 0.196s
Writing xbl_config.elf [elf:120.66 KiB]->xbl_config... OK 0.105s
Writing gpt_main1.bin [raw:24 KiB]->PrimaryGPT... OK 0.102s
Writing gpt_backup1.bin [raw:20 KiB]->BackupGPT... OK 0.101s
Applying patch1.xml... OK

Processing LUN2 - rawprogram2.xml

Writing gpt_main2.bin [raw:24 KiB]->PrimaryGPT... OK 0.102s
Writing gpt_backup2.bin [raw:20 KiB]->BackupGPT... OK 0.102s
Applying patch2.xml... OK

Processing LUN3 - rawprogram3.xml

Writing oppo19710.bin [raw:48 bytes]->cdt... OK 0.051s
Writing zeros_5sectors.bin [raw:20 KiB]->ddr... OK 0.102s
Writing gpt_main3.bin [raw:24 KiB]->PrimaryGPT... OK 0.052s
Writing gpt_backup3.bin [raw:20 KiB]->BackupGPT... OK 0.102s
Applying patch3.xml... OK

Processing LUN4 - rawprogram4.xml

Writing aop.mbn [elf:196.05 KiB]->aop... OK 0.106s
Writing tz.mbn [elf:3.04 MiB]->tz... OK 0.195s
Writing hyp.mbn [elf:476.88 KiB]->hyp... OK 0.148s
Writing NON-HLOS.bin [fat:140.21 MiB]->modem... OK 3.515s
Writing BTFM.bin [fat:860 KiB]->bluetooth... OK 0.126s
Writing abl.elf [elf:160 KiB]->abl... OK 0.106s
Writing dspso.bin [ext4:64 MiB]->dsp... OK 1.689s
Writing km4.mbn [elf:253.03 KiB]->keymaster... OK 0.108s
Writing boot.img [kernel:96 MiB]->boot... OK 2.368s
Writing cmnlib.mbn [elf:385.75 KiB]->cmnlib... OK 0.113s
Writing cmnlib64.mbn [elf:503.61 KiB]->cmnlib64... OK 0.115s
Writing devcfg.mbn [elf:52.79 KiB]->devcfg... OK 0.103s
Writing qupv3fw.elf [elf:69.07 KiB]->qupfw... OK 0.103s
Writing vbmeta.img [raw:8 KiB]->vbmeta... OK 0.101s
Writing vbmeta_system.img [raw:4 KiB]->vbmeta_system... OK 0.051s
Writing vbmeta_vendor.img [raw:4 KiB]->vbmeta_vendor... OK 0.051s
Writing dtbo.img [raw:24 MiB]->dtbo... OK 0.760s
Writing recovery.img [kernel:80 MiB]->recovery... OK 2.087s
Writing uefi_sec.mbn [elf:122.62 KiB]->uefisecapp... OK 0.104s
Writing imagefv.elf [elf:30.5 KiB]->imagefv... OK 0.102s
Writing dpAP.mbn [elf:13.19 KiB]->apdp... OK 0.101s
Writing dpMSA.mbn [elf:13.19 KiB]->msadp... OK 0.102s
Writing splash.img [raw:516.63 KiB]->splash... OK 0.117s
Writing logfs_ufs_8mb.bin [fat:16 KiB]->logfs... OK 0.102s
Writing storsec.mbn [elf:20.08 KiB]->storsec... OK 0.103s
Writing oppo_sec.mbn [elf:111.52 KiB]->oppo_sec... OK 0.104s
Writing multi_image.mbn [elf:13.3 KiB]->multiimgoem... OK 0.103s
Writing sec_smt.dat [raw:512 bytes]->secdata... OK 0.102s
Writing gpt_main4.bin [raw:24 KiB]->PrimaryGPT... OK 0.102s
Writing gpt_backup4.bin [raw:20 KiB]->BackupGPT... OK 0.103s
Applying patch4.xml... OK

Processing LUN5 - rawprogram5.xml

Writing dynamic_nvbk.bin [raw:10 MiB]->oppodycnvbk... OK 0.446s
Writing static_nvbk.bin [raw:10 MiB]->oppostanvbk... OK 0.434s
Writing emmc_fw.bin [raw:4 MiB]->opporeserve1... OK 0.349s
Writing opporeserve2.img [sparse:5.05 MiB]->opporeserve2... OK 0.398s
Writing DRIVER.ISO [raw:22.69 MiB]->DRIVER... OK 0.685s
Writing gpt_main5.bin [raw:24 KiB]->PrimaryGPT... OK 0.102s
Writing gpt_backup5.bin [raw:20 KiB]->BackupGPT... OK 0.102s
Applying patch5.xml... OK
Rebooting... OK
Total transfer : 7.97 GiB
Transfer Speed : 38.14 MiB/s


UNLOCKTOOL
2023.05.25.0
Elapsed time : 4 minutes 14 seconds
 

deadmau0703

Member
Oct 21, 2022
9
0
algeria
try this firmware bro realmeX3RMX2086
I did everything , i have UnlockTool.

i flashed all these roms :
RMX2086GDPR_11_F.06_2022101321340000.zip
RMX2086GDPR_11_C.13_2022051901570000.zip
RMX2086export_11_C.13_2022051901560000.zip
RMX2086PU_11_A.33_200625_33c9c266.zip
RMX2085export_11_C.13_2022051901550466_2.7z
RMX2081PU_11_A.53_210404_719ee533.zip
RMX2081EU_11_A.52_210404_719ee533.zip
RMX2081PU_11_A.53_210404_719ee533.zip

I extracted all of them , flashed them one by one , one time using Unlocktool , the 2nd time using Qfil after making some changes in Rawprogram3.xml "oppo19711.bin in cdt" and Rawprogram4.xml " sec_smt.dat in secdata ".
i edited Rawprogram.xml and got rid of those weird logs from Port_trace.txt " QFil logs ".

I try to keep the battery voltage from being sucked by the phone " i keep it above 3.7V " , the phone always is drawing from 0.20 A to 0.32 A using my usb doctor.

Sometimes QFil won't flash unless i use prog_fwupdate.mbn , prog_firehose.mbn won't work .

The phone won't automatically connect to the pc ''9008" unless you short testpoint , and fix this "sometime" i use Format Storage from UnlockTool , then the phone will automatically get detected by the pc ''9008" eachtime you plug it or unplug it from the pc , it will get recognized without shorting the pins.

Before getting to this point , the phone was working fine i installed a custom rom and everything was ok. when i tried to root it i faced many problems of the phone not booting etc , i used to fix everything just by flashing "RMX2086GDPR_11_C.13_2022051901570000.zip" then the phone will boot without a problem , as a fresh start or something then i start ''rooting and installing custom roms etc ''
 

deadmau0703

Member
Oct 21, 2022
9
0
algeria
chips off then backup importante file

emmc erase/file

write backup like csd/boot file/userdata

then after that full flash with this firmware Redirecting...
it didn't work and i'm using ''9008" only , i mean i don't have Emmc writer or UFS and other powerful boxes , i'm using QFil and UnlockTool only , any advice about a paid software that is more powerful than Unlocktool '' without a dongle " i don't want to wait for the dongle to flash again.

Today i tried 3 diff roms :
RMX2085_11_A.41_200822_RFT
RMX2085export_11_C.03_202102262223
RMX2085_11_C.06_2021051813110397

I used to revive this phone using a firmware that don't have a bigger userdata , it has 3 super_sparses and no preload.special.img.
Because my brother broke it while rooting too many times and i never had a problem reviving it . now i tried every firmware nothing.
 
Top